JETI LiVal Changelog

Version history of JETI LiVal (Last updated on May 21, 2021)

V7.0.0

[NEW]
- Support for devices with stray light correction
- Blue Measurement - Widget
- Optional screen darkening during the measuring process
- Hazard measurements:
  * Alternative method of hazard measurement for blue light, retina thermal and retina thermal weak in irradiance measurement mode
  * User guidance for blue light measurement according to IEC 62471
- Calculation of Luminous Exposure (Hv) and Radiant Exposure (He):
   * If using table view: only available for continuous measurement in Irradiance measurement mode
   * If using history view: available in irradiance measurement mode over all current measurements
- Spectral calculations: Added display options "Log scale", "Normed" and "Colored" as well as the display of all measurements or only the active measurement similar to "Preset/Spectrum".
- Widget "Circadian Metrics": Added calculation of Xv,mel,D65 (MEDI) and mv,mel,D65 (MDER)
- L*a*b (plane)- Widget: Added selection option all measurements / active measurement
- Added export as Instrument Systems Data File .isd

[CHANGED]
- PDF export redesigned and extended (free text, heading, footer, page break, export of the Hazard and Blue Measurement values, additional setting options)
- Table:
   * Table window redesigned
   * When changing the measurement mode or calibration file, the entries shown in the table are no longer always deleted and can still be exported. The actually measured values are deleted as before.
  * The table can now be copied to clipboard including row labels.
- Hazard measurement redesigned:
  * The calculation is now only available in Radiance and Irradiance measurement mode.
  * Settings for future measurements (left widget side) and the display of the measurement results (right side) are now independent
  * In Radiance mode, the set Fov must necessarily correspond to the Fov of the calibration file, otherwise measurement will not be carried out
  * The calculation and displayed values are based on the calibrated wavelength range of the selected measurement, no longer on the wavelength range of the currently connected device and also independent of the selected Calculation Range.
- Measurement mode Radiant Intensity:
  * Distance query removed from the menu items "Options/Photometric units/SI Units" and "Options/Photometric units/Imperial units"
  * When loading the saved measurements from SPC, CSV and Temp files, the distance is now read from the file.
- revised correction measurement with auxiliary lamp in Radiant Flux measuring mode and saving/loading of different correction spectra enabled
- Extended of the wavelength range to support NIR radiometers
- Purely photometric widgets and menu items are now hidden if the entire measured spectrum is outside 380-780 nm
- extended tooltips in the custom window
- Added possibility to save the last target setting with and without focus and automatically adjust it according to the calibration file.
- minor GUI changes

[BUGFIX]
- Line shift in table with metamerism display in UV range -> fixed
- Program crash when exporting a large number of measurements to an SPC file -> fixed
- History: Jumbled of graphs when reading stored measured values -> fixed by time sorting
- Missing error message that LiVal cannot be started if the screen resolution is too low -> fixed
- Endless query after switching to another measuring mode with active sensor and answering the question whether all measured data should be discarded with "No" -> fixed
- When answering the question about changing the measuring mode with "No", the menu, button labelling and setting of the measuring mode were not completely reset in some cases -> fixed
- When restoring unsaved measurements, the measurement mode was not checked. As a result, it could happen that measured values with different measuring modes were loaded and displayed in the wrong measuring mode. -> fixed
- Measurement mode Radiant Intensity: In the online mode, the label for the measuring distance of the offline mode was displayed on the measuring button in addition to the actual button labelling -> fixed
- PDF export: Units for Circadian corrected
- When loading CSV and SPC files in offline mode, the menu selection was not changed when switching the measurement mode and summer/winter time was ignored when loading and saving SPC files -> fixed
- Simultaneous display of different messages led to incorrect display text and to the program hanging up -> fixed
- Change of measurement mode or calibration file during a continuous measurement was not detected -> fixed
- Read-in measurement results could only be displayed if at least 2 measurements were present in the selection list -> fixed
- Correction measurement with auxiliary lamp: after cancelling, the procedure did not start correctly again -> fixed
- Error message for overexposure missing when laser mode is switched on -> fixed
- Sometimes there was an incorrect displayed spectrum when logarithmic y-scale was chosen -> improved

V6.16.5

[BUGFIX]
- Program crash during CSV export of table values with long label -> fixed

V6.16.3

[CHANGED]
- company address

[BUGFIX]
- the spectral weighting function could be shifted if the wavelength ranges do not match the measured spectrum -> fixed

V6.16.2

[CHANGED]
- Mode designator in saved (or user created) reference files is not case-sensitive anymore. The same for "MODEL". (For lamp files, the mode was already not case-sensitive).

[BUGFIX]
- "Choose Standard Illuminant"-utility showed false settings if called before an RGB-Widget has been displayed somewhere. -> fixed

V6.16.0

[NEW]
- Export as PDF report
- Museum Lighting Damage - widget
- Color Difference Widget (CIE76, CIEDE2000)
- Save as .CSV and .SPC: information about hazard calculation and museum lighting damage modes can be saved (to make calculations correctly if loading). Checkboxes in the "Save" window.
- TM-30-18 standard (replaced TM-30-15); Color Vector Graphic (CVG) widget correspondingly updated
- Hazard: measuring mode and viewing angle are saved for every measurement. This information is exported into the table and in Excel.
- and + shortcuts to switch presets
- Basic device parameters are logged in an individual file named by device number.

[CHANGED]
- Maximum number of points for xy-polygons supported by Pass/Fail and Rank View increased to 15.
- New custom made message boxes with icons.
- Behaviour of transferring of measurements to table, saving them as reference and building a PDF-report from them is unified. Three buttons below the legend instead of menu items.
- "Measuring mode"-drop-down-list appears only in offline mode. With device connected, the mode is displayed inside the "Measurement" button.
- Hazard: settings in the widget have influence only on subsequent measurements (not on previous; nothing is recalculated if settings are changed)
- Hazard: Now, Hazard is not calculated if some Spectral Weighting Function is loaded (to avoid confusion with double-applied weighting functions). If that's a case, a notice about it is shown in the Hazard-widget.
- Hazard: Options->Table - if Hazard is checked, Calibration File is also checked and dimmed to make it impossible to unckeck it.

[BUGFIX]
- Hazard: Maximum time in Retina Thermal Weak mode had no upper limit. -> fixed (now it is 28800 seconds = 8 hours, after what it gets the value of PositiveInfinity)
- PromptPopup (dialog to enter a string) had false behaviour: if input something and clicked with a mouse somewhere in the dialog, always the same event as after clicking on the "OK"-button has been fired. -> fixed
- Export of multiple measurements in .CSV could take long because of a bug in .CSV-exporting routine. -> fixed
- Calibrations which have zeroes could cause crash -> fixed
- Laser intensity has not been changed if applying focusing optics to a spectraval device. -> fixed

V6.14.3

[BUGFIX]
- The spectral weighting function could be shifted if the wavelength ranges do not match the measured spectrum. -> fixed

V6.14.2

[BUGFIX]
- Setup and Program where not digitally signed -> fixed

V6.14.1

[NEW]
- Import from SD-card - files are deselected in the list during operation.
- Import from SD-card - It is possible to cancel operation by closing of the progress bar.

[BUGFIX]
- Import from SD-card - opening of other windows or applications during import caused LiVal to look like a crash ("no response" etc.). -> fixed

V6.14.0

[NEW]
- 2 custom presets added
- Preset-Backward and Preset-Forward arrow buttons
- Functions Ssc, Slc, Smc, Smel, Srh (circadian norm 2018), CIE1931 and CIE1964 x,y,z in distribution
- "ipRGC-Influenced Responses to Light" widget (5 curves; 5 corresponding values)
- History widget: view of total time
- Menu/Options/TM-30-15. Show Rf&Rg in the angled chart on/off, precision and font size
- Treating of adaption failure error in case of continuous mode. Creating of empty measurements marked red in the legend

[CHANGED]
- Minimum value of sync.-frequency numeric control is now 0.1 Hz. If setting to a frequency < 16 Hz fails because of hardware restrictions, it is set to 16 Hz
- Integration time < 1 ms for specbos1211 devices equipped with corresponding hard- and firmware is supported

[BUGFIX]
- Saving of a calibration to device didn't always work with boudrate=3000000. -> fixed
- If sensor mode is switched to "Sensor disabled" and then back to "Sensor active", a message box came that the measuring mode has been changed anyway. -> fixed
- In case of fixed-tint-measurements value of "adapted averages" was 0, what led to improper values in the table. -> fixed
- Labelling of ranks was not nice on xy-chart. -> fixed

V6.12.0

[NEW]
- Two widgets for L*u*v* color space: L*u*v* and sC*h.
- "Spectral Calculation" widget: Lv, x, y values of the calcualtion result spectrum.
- Continuous mode - schedule: possibility to set start and end time, a break and periodicity of continuous measurement.
- Capture: streaming of continuously measured spectra into a file for security with very long continuous measurement series.
- History-chart: possibility to click on some data point to jump to corresponding measurements in the legend.
- History-chart: x-axis can have sense of absolute time or of measurement number (switch).
- Offline mode: if there are no measurements and the user tries to open a reference file in another measuring mode than the current, the current measuring mode is automatically switched.
- Export of Sync.-frequency into the table and into the Excel.
- After exporting an Excel table, option to open the target directory.
- "Target"-button in the calibration panel.

[CHANGED]
- Batch operations with large amounts of data and the table are optimized: instead of allocating small memory blocks many times, one large block is allocated etc.; instead of adding always 1 column to the table, many columns are added with one operation. This increases the speed much: for example, it is possible to transfer 65000 measurements to the table within a reasonable time.
- Calculations of CRI and CQS values were performed for spectra with 5 nm step which consisted of every 5th value of original measured spectra (because calculations are defined for 5 nm step via standards). Now the spectra for CRI and CQS calculation consist of averages of 5 values of original spectra. This improves stability of calculation results.

[BUGFIX]
- Blue cursor in xy- and u'v'-charts was invisible if zoomed in to blue -> fixed (cursors are black now)
- Offline mode: table was not reinitialized if measuring mode has been changed. -> fixed
- Raw spectrum: wavelength and a value on it stood dimmed even after a successful measurement. -> fixed
- Table: memory errors have not been treated. -> fixed
- TimeStamp as seconds since 1.1.1900 for loaded CSV or SPC files hasn't been calculated -> fixed
- Before sync-measurements, laser has not been switched off. -> fixed

V6.10.0

[NEW]
- Support of accessories for spectraval (through JETI DLLs 4.4.1)
- Overexposured measuring are marked with red and have "(Overexposure!)" as name prefix.
- Right click on indicators with numeric results displays an 1-item pop-up menu "Copy value". If clicked on it, the value is copied to clipboard.
- Spectral weighting function in the main panel.
- Hazard - equation result multiplied by alpha for Retinal thermal modes.
- Export of calibration file name, averages-setting, battery voltage and battery percentage in Excel and in the table.
- History-widget: possibility to track battery voltage and percentage.

[CHANGED]
- Changes in main panel layout.

[BUGFIX]
- Uncalibrated device caused crash with "simple spectrum"-widget -> fixed
- Uncalibrated device + "target->laser on after measurement" didn't work -> fixed
- Load SPC with many measurements - memory error due to unnecessary amounts of allocated memory. -> fixed
- Calculations of XYZ->Lab and CRI had errors with dividing by 0. -> fixed
- Calculations for spectra that are like noise around of 0-line sometimes caused a domain error with pow-function (negative value with float power is illegal) -> fixed
- Savitzky-Golay-Filter has not worked. -> fixed

V6.8.4

[BUGFIX]
- File->Save - list of spectra has not worked -> fixed

V6.8.3

[NEW]
- 3 attempts to read calibration files if error.

V6.8.2

[BUGFIX]
- SPC files were saved incorrect for multiple spectra with different wavelength ranges (that happens e.g. if switching calibrations for hazard within the same measuring mode). -> fixed (SPC for multiple measurements are always in XYXY-format now).
- Loading of SPC - time localizing made timestamp false. -> fixed
- Tab-order in "Select Measurements to Be Saved"-window was wrong. -> fixed
- (usability): Options->RGB - it was impossible to switch between measurements in the legend of the main panel, what made using of "Get"-buttons very cumbersome. -> fixed

V6.8.1

[BUGFIX]
- Offline + load - incorrect scaling (due to missing calibration WL-range) -> fixed

V6.8.0

[NEW WIDGETS]
- Transmission measurement.
- "Spectrum (simple)" widget for the "Measuring results field".
- dE2000.
- L*a*b*. Num&chart widgets + L*a*b* settings.
- CIE2017 Color Fidelity Index (CFI). 2 widgets.
- "TM-30-15 all Rf values" (Additional widget for TM-30-15).

[NEW FEATURES FOR EXISTING WIDGETS]
- History: Le (extended), 6 ranges as an option for the value to be tracked.
- History: some additional values can be shown - Min, Max, Max-Min, 100%*(Max-Min)/(Max+Min), Average.
- Hazard: 3 hazard types more (Eye IR, Skin thermal, Retinal thermal for weak visual stimulus).
- Hazard: red color & strikeout for limits in the equation if "calculation range" settings limit them additionally.
- Hazard: output of equation result.
- Raw spectrum: output into the table and Excel; ZOOM-features in Raw Spectrum Chart.
- xy and u'v' charts: "Show all/active" - switch.

[NEW GENERAL SOFTWARE FEATURES]
- Generally, it is possible to make measurements with an uncalibrated device (only Raw Spectrum and Transmission are shown in this case).
- Custom preset: possibility to save the settings into a .DAT file.
- Output of the time stamp as seconds since midnight 01.01.1900 with milliseconds (table, Excel).
- Batch changing of plot options is possible for all selected measurements.
- CTRL+L shortkey to switch the laser. It ignores measuring mode and works also with diffusor.
- Quick mode: setting for upper limit of integration time.
- Quick mode: setting for time between repeating dark measurements.
- Quick mode: works also in combination with fixed integration time.
- If device type is specbos1211, 12 calibrations are possible.
- Calibration panel: "Copy to clipboard"-button.
- Calibration measurement can be interrupted with ESC.

[CHANGED]
- Calibration panel completely revised.
- Circadian: constants are linearly interpolated (from 5 to 1 nm step) before usage.

[BUGFIX]
- Right click on an item in the legend after multiple choice caused deselect all. -> fixed
- Calculation range for radiance hasn't changed after (re)calibration. -> fixed
- Options/Table: Table has been always updated after clicking on "OK", even if nothing had been changed -> fixed


V6.6.2

[BUGFIX]
- Loading of SPC-file: superfluos localizing of timestamp has made it false. -> fixed (localtime -> gmtime).

[BUGFIX]
- ZOOM-reset in the spectrum chart hasn't work. -> fixed.

[BUGFIX]
- OFFLINE - battery menu was active and has shown "battery low"-warning -> fixed.

V6.6.1

[BUGFIX]
- Rename of measurements - old name hasn't been shown correctly in dialogs. -> fixed.

[BUGFIX]
- Hazard - export to Excel: instead of "+inf" it was something like "#1INF" and there were "problems" if trying to open the saved Excel file. -> fixed ("+Inf" is now exported as string, because Excel has no number for numerical infinities).

[BUGFIX]
- Busy JETI-LAN-devices have appeared in the device list. -> fixed (through DLLs 4.0.17)

V6.6.0

[NEW]
- Hazard (calculations, widget, export into table).
- TLMF (calculation, widget, export into table).
- Le (extended) widget with 6 radiometric values. Export to table and Excel.
- CIE2006 TU Ilmenau modified CMFs for 2° and 10°.
- Menu/Options/Luminous efficiency function. Lv values get corresponding index.
- Re index for CRI. Changes in all affected CRI-widgets and in the summary table.
- Extras->Max. Signal Targeting Help: quick measurements for device adjustment.
- Quick mode
- Auto-zoom option for XY and U'V' charts.
- Tolerances for primary colors for RGB color spaces to be displayed in XY and U'V' charts together with RGB-triangles.

[CHANGED]
- "Target on" causes laser to turn on after each measurement in a continuous series.
- Menu->Options->Integration Time instead of Instrument Settings. Fixed tint setting is now here.
- RGB white point on XY and U'V' charts is labelled only with "Show RGB color triangle" option turned on.

[BUGFIX]
- History - if X-axis label is longer than 5 characters, 5 last characters are token.
- "Normed" in spectrum chart has used spectral maximum only within "calculation range" of radiance. -> fixed
- Export in Excel: on default no observer was selected. -> fixed (now on default CIE1931 2° is selected).
- Result of CCT calculation in some cases (e.g. with x=0.2252, y=0.2163) caused NaN. -> fixed
- CIE2015 CMFs removed, CIE2006 - corrected. Index for CIE2006 changed to "F" (as in standard).
- Multiple graphical and stability issues.

V6.4.5

[CHANGED]
- "Estimated time" for spectraval for multiple averages (because of firmware changes).

[CHANGED]
- Export in Excel: on default no observer was selected. -> fixed (now on default CIE1931 2° is selected).

V6.4.4

[CHANGED]
- Condition for interpolation of calibrations changed to <=0.

V6.4.3

[NEW]
- Options->RGB - "ITU-R Rec 2020 UHD" renamed to "ITU-R Rec.2020 / Rec.2100"; because there is a new standard, and rbgw coordinates for it are the same.

[BUGFIX]
- Problems with searching for LAN-devices (alien devices could be found) -> fixed throug DLLs V4.0.13.

V6.4.2

[CHANGED]
- RGB sensitivity default value = 100%.

[BUGFIX]
- LAN-devices didn't work -> fixed through DLLs V4.0.12.

V6.4.1

[NEW]
- Demo calibrations for radiant flux and radiant intensity

V6.4.0

[NEW]
- IES TM-30-15 calculation and 7 widgets for displaying of its results.
- History (tracking) widget.
- New sets of Color Matching Functions (CMFs): CIE2006 2° Schanda-Csuti modified, CIE2015 2° and 10°
- Separate setting of user selected range for radiance calculation, which is not connected with settings of spectrum chart.
- More standard illuminant settings for CRI.
- Planckian locus is calculated and displayed for all CMFs.
- Snap-to-grid feature in "Custom" preset. Widgets can be easier arranged.

[BUGFIX]
- Performance improvements (scaling and zooming problems in case of many measurements).
- Multiple major stability problems with spectraval (especially operated via BlueTooth); treating and logging of errors.

V6.2.0

[NEW]
- Support of spectraval (new generation of JETI devices).
- Export of measured spectra as ZEMAX .spcd.
- RGB column chart with many standard color spaces in a list.
- New sets of Color Matching Functions (CMFs): CIE2006 2° and Judd-Vos 1978 2°.
- Session logging.

[BUGFIX]
- Multiple minor issues concerning graphical user interface and program stability.

V6.0.5

[NEW]
- Customizable presets/widgets-concept of displaying of measured values.

- New values and displays:
CRI column chart, CRI circle chart
CQS column chart, CQS CIELAB chart (with Qf, Qp and Qg values)
TLCI table, TLCI EBU R137 report
Duv

- Circadian constant sets are selectable between 2009 and 2015 standards.

- At start, LiVal tries to connect to the last used device first of all to save time. To change this default behaviour, following command line arguments can be used:
Arg1 = COM/FTDI/TCPIP/BT / SEARCH/OFFLINE
Arg2 = COM-port#/ USB-SN/ TCPIP/BlutTooth address, if Arg1=COM/FTDI/TCPIP/BT

- "Log scale" and "Normed"-switches for spectrum chart.

- Play sound after the measurement ends.

[BUGFIX]
- Graphical issues if very large or very small monitor is used. -> Fixed.
- Duv calculation: negative values must be allowed if the measured chromaticity coordinates are beneath the Planckian locus. -> Fixed.
- Start with connected Bluetooth devices could cause crash. -> Fixed.

V5.2.4

[BUGFIX]
- with TCP/IP connection changing the measuring head was not recognized -> fixed

V5.2.3

[BUGFIX]
- software could crash when loading CSV reference file with radiant intensity values -> fixed


V5.2.2

[BUGFIX]
- software could crash during start with connected bluetooth device -> fixed


V5.2.1

[BUGFIX]
- minor baseline error in calibration of UV-devices -> fixed


V5.2.0

[NEW]
- Reconnect automatically on connection errors
[CHANGE]
- UV correction not performed by software LiVal but only by firmware


V5.0.7

[BUGFIX]
- Metamerism calculation with non-UV-devices was wrong -> fixed


V5.0.6

[BUGFIX]
- If software was started in Radiant Intensity mode, wrong units were not dimmed -> fixed


V5.0.5

[BUGFIX]
- Spectral data were not deleted in some cases if the measurement was deleted -> fixed
- Setting for metamerism export was not saved -> fixed


V5.0.4

[BUGFIX]
- Metamerism data could not be exported in some cases -> fixed


V5.0.3

[BUGFIX]
- Quality grade dependency on du'v' was neglected -> fixed
- Metamerism panel was not cleared if data were deleted -> fixed
- Selection of illuminant in metamerism panel was dimmed sometimes -> fixed


V5.0.1

[BUGFIX]
- compiled with JETI_SDK V3.2.3 -> "could not write calibration data" -> fixed
LiVal


V5.0.0

[NEW]
- JETI LiMeS renamed into JETI LiVal
- Adaption of integration time is now done by firmware
- Introduction of sync measurement and handling (manual or automatically measured frequency)
- Useage of action spectra
- UV and offset correction possible (*para:correna)
- not stored measuring data can be reconstructed after program crash
- a small information window can be overlayed for each measurement and reference
[CHANGE]
- Communication with device via JETI DLLs
- more than one spectra can be stored in a reference file and reloaded afterwards
- menu of table view (Sort, ...) is hidden
- measuring mode for pulsed light (specbos 1201 flash) was removed
- Colorimetric values will be always calculated for 2° and 10° observer simultaneously
- Colorimetric values can be exported as 2° and/ or 10°
- CRI is always calculated independend of the observer setting (with 2° observer)
- the zoom level for xy and u´v´diagrams is limited
- Arithmetic operation of spectral calculation will be indicated
- cursor will be blanked out for screen shots
[BUGFIX]
- Display of remaining time was not always correct -> fixed
- Radiometric value was sometimes calculated not correctly (user selected range) -> fixed
- Wavelength range in export panel was not checked with regard to invalid values -> fixed
- Legend of table was not correct after 'Clear All'-> fixed
- Selection of measurements in different views was not correct -> fixed
LiMeS


V4.9.1

[NEW]
- light classification shown in Metamerism-Panel
[BUGFIX]
- error in metamerism calculation -> fixed
- timeout (lost connection) at long measurements -> fixed
- average at fixed integration time not possible -> fixed


V4.9.0

[NEW]
- metamerism calculation included
[BUGFIX]
- during spectrum refresh cursor could not be set -> fixed
- no refresh of xy- and u'v'-diagram after measurement -> fixed


V4.8.1

[CHANGE]
- small corrections in About-Panel


V4.8.0

[NEW]
- weighting function for PAR calculation


V4.7.4

[BUGFIX]
- If unit (specbos 1201) is not calibrated, no more infinite warning loop


V4.7.3

[CHANGED]
- Changing of graph properties via context menu, not via double click in the legend
- Excel export via LibXL libraty (no crash any more)
- Possibility of Export of xls, xlsx and csv
- CCT dimmed if 10° observer is used, no export, no Planckian curve
- no error message after aborting a measurement
- Timestamp in table extended to seconds
- Changed adaption (with reference measurements)
[BUGFIX]
- Format of time and date corrected
- sometimes no actualization of values after a measurement -> corrected
- Lamp Stability Check corrected


V4.7.2

[BUGFIX]
- specbos 1211 LAN (via RealPort) was set to false Baud rate -> corrected
- False Baud rate in About window -> corrected


V4.7.1

[CHANGED]
- PAR values in scientific notation


V4.7.0

[NEW]
- PAR calculation in addition for 5 selected wavelength ranges


V4.6.3

[CHANGED]
- CCT calculation according to Y. Ohno
- no CCT with 10° observer selected
- STRG+C copies table content into clipboard (previous the calibration panel was popped up)


V4.6.2

[NEW]
- Savitzky-Golay smoothing introduced
[CHANGED]
- negative spectral values are not cut any more


V4.6.1

[CHANGED]
- Compiled with CVI 2010 SP1 (previously CVI 2009 SP1)


V4.6.0

[NEW]
- Calculation of ratio of integral values of two selected wavelength ranges
[CHANGED]
- Data export now directly into xls file (via Excel DLL) and not any more into Excel started in background


V4.5.3

[BUGFIX]
- Additional error in switching measuring head removed


V4.5.2

[BUGFIX]
- Error in switching measuring head removed


V4.5.1

[NEW]
- Name will be proposed during storage of calibration file
[BUGFIX]
- Switching of measuring head with missing calibration changed


V4.5.0

[NEW]
- Battery status of accumulator driven instrument is shown
[CHANGED]
- Port will be closed in case of heavy communication errors


V4.4.0

[NEW]
- Color values CIE XYZ can be displayed and exported (Excel, CSV)
[CHANGED]
- Timeout of FetchSpectrum changed from 100ms to 500ms


V4.3.0

[NEW]
- Single flash measurement also possible in Radiant flux mode
- Fixed integration time of single flash measurement can be changed


V4.2.0

[NEW]
- Correction measurement for sphere with auxiliary lamp
- Stability check of a light source
[CHANGED]
- Redundant inscrition (nm) of table labeling of spectrum removed
[BUGFIX]
- Error in zooming removed


V4.1.0

[NEW]
- Raw spectrum will be stored in RAM too
- Weighting functions now possible with unit
- COM port will be released automatically and new initialized during wake up in case of suspend mode
[CHANGED]
- Raw spectrum always from 200 to 1000nm
- Default directory will be user directory if not selected otherwise
[BUGFIX]
- Multi selection in spectrum list corrected (legend)
- During release of COM port the timer will be stopped


V4.0.3

[NEW]
- No flashing of laser and maximum 2.5% intensity in case of focus units
[CHANGED]
- 'Clear Always' and 'Clear Never' deleted, now selection between display of all measurements or only active one in spectral diagram display


V4.0.2

[BUGFIX]
- XYZ calculation for 10° observer corrected
- False Excel output of radiometric spectrum in connection with action spectrum corrected


V4.0.1

[BUGFIX]
- False wavelength range during display of weighted spectrum removed


V4.0.0

[NEW]
- Useage of user specified weighting functions and spectral calculations
- Status of window (maximized or not) will be restored after restart of program
- no direct Excel export any more, but adaptable internal table, which can be exported as XLS/XLSX or CSV file
- during export of table into CSV the PC country settings are considered
- Display of numbers in program are also country specific (decimal separator)
[CHANGED]
- Continuous measurement possible without fixed integration time or hold of integration time
- Device will be set to default values during finishing of program
- Target laser will be switched on automatically after measurement (selectable in options menu)
- Wavelength range for export of spectrum in table can be selected
[BUGFIX]
- RGB will be deleted correctly
- Correction of maxcounts display (F12)


V3.5.6

[CHANGEDG]
- Laser can be switched on automatically after measurement (selectable in menu options)


V3.5.5

[CHANGED]
- Laser will be switched off during measurement and remains switched off afterwards (as to vers. 3.5.3.)


V3.5.4

[CHANGED]
- Laser remains switched on, will only be switched off during a measurement
[BUGFIX]
- PAR calculation corrected
- height of list of measuring files adapted (no overlap any more)
- corrects the display of y axis labeling


V3.5.3

[CHANGED]
- Background figures of diagrams again as extra figures


V3.5.2

[CHANGED]
- If no CCT calculated, the no CRI calculation by default
[BUGFIX]
- Corrected calculation of remaining time
- Display of unit of radiometric value corrected
- Adaption algorithm corrected


V3.5.1

[BUGFIX]
- internal bugfix


V3.5.0

[NEW]
- Software can be triggered by the instrument
[CHANGED]
- Pictures used in program are stored in UIR and not in extra files any more
[BUGFIX]
- internal bugfix


V3.4.2

[NEW]
- Interface can be deactivated and activated without finishing of the program
[CHANGED]
- Spectral diagram without colored line, but area beneath the spectrum filled by appropriate color
- Reduced column width in Excel
[BUGFIX]
- False labeling of Radiance corrected


V3.4.1

[CHANGE]
- Extension of waiting time for loading of calibration data


V3.4.0

[NEW]
- Calculation of RGB values
- Program warning message , if measurements are not stored
- more than one spectrum can be selected for Excel export and deletion
- Number format of radio and photometric values can be switched between floating point and scientific notation
- Supports up to 16384 columns in Excel export (Excel 2007)
- previous loaded or stored file format (SPC or CSV) will be saved
[CHANGED]
- Change in CCT calculation (formula of 10° observer)
- possible start wavelength 190 nm, end wavelength 2500 nm
- Name of spectrum during Excel export is not asked separately
- Speed up of Excel export
- maximum size of McAdams ellipses increased to 10
- minimum panel size reduced to 1024 x 600 (typical resolution of new netbooks)
[BUGFIX]
- Calculation of centroid wavelength corrected
- Adjustment of font size at panel zoom


V3.3.0

[NEW]
- measuring mode for pulsed light sources and single flash
- special calculation window for LED values (FWHM, Peak, centroid)
- measuring distance (radiant intensity) will be saved and displayed
- user-defined wavelength range for radiometric value calculation
- changeable measurement name (via popup-menu)
[CHANGED]
- Calculation of spectral integral changed, Addition of mean value of neigbouring values
- Name of Excel column in own dialog asked with proposed name
- Color temperature (CCT), dominate wavelength (DWl) and color purity (PE) in Excel table with full words
- If no CCT calculated, the entry will be dimmed
[BUGFIX]
- Search of maximum beginning only at pixel 2 (Workaround)


V3.2.1

[BUGFIX]
- program start takes very long on some Windows 2000 systems -> fixed


V3.2.0

[NEW]
- user-defined ellipse (for pass/fail-test) can be saved and loaded
- graph labels can be switched on and off
- calibration files can be deleted from device
[CHANGED]
- all ranks will be saved - improved background pictures in 10° xy- and u'v'-diagrams
[BUGFIX]
- communication timeout too short in some cases -> fixed
- error, if calibration file has resolution other than 1nm -> fixed


V3.1.2

[BUGFIX]
- calibration file could not be send to device if user has no administrative privileges -> fixed


V3.1.1

[CHANGED]
- improved adaption
[BUGFIX]
- error in calculation of circadian metrics -> fixed
- replaced ftL with fL (new syntax)


V3.1.0

[NEW]
- switch between SI and imperial units
- new big display of numerical measuring values
[CHANGED]
- support of new JETI devices (identifier JETI_...)
[BUGFIX]
- no refresh of rank view in some cases -> fixed


V3.0.2

[BUGFIX]
- error if measuring mode is switched manually -> fixed
- could not find devices with com-ports >9 -> fixed


V3.0.1

[NEW]
- new button 'Delete' in Rank-Edit panel to clear memory
- keep path to rank files
[CHANGED]
- new main menu entry 'Excel'
[BUGFIX]
- rank files could not be loaded correctly -> fixed


V3.0.0

[NEW]
- new measurement mode 'Rank'
- new sample (nr. 15) for CRI
- laser can be dimmed
- measuring mode and calibration file is shown in main window
- switchable measuring mode in offline-mode
[CHANGED]
- zoomable xy- and u'v'-diagrams even without displayed measuring values
[BUGFIX]
- in some cases divide-by-zero error -> fixed
- sometimes device could not be identified -> fixed


V2.0.5

[NEW]
- com-port can be set as argument when program starts


V2.0.4

[CHANGED]
- improved speed of calibration file table
[BUGFIX]
- error during send of calibration data -> fixed


V2.0.3

[CHANGED]
- use minimum integration time and minimum and maximum adaption border from device parameter


V2.0.2

[BUGFIX]
- error after manual switching after calibration -> fixed
- incorrect CRI sample values in const.dat -> fixed


V2.0.1

[BUGFIX]
- error loading const.dat -> fixed
- new const.dat


V2.0.0

[NEW]
- pass/fail with min-max-test for radiometric and photometric values
- pass/fail with polygons and McAdams ellipse for chromaticity coordinates xy
- load, save and view calibration files
- hall sensor can be deactivated (manual switching calibration file)
- calibration files in arbitrary order
[CHANGED]
- change distance for radiant flux with CTRL-D
- calibration files must not be saved on disk during calibration process
- new arrangement of menu entries
- keep light source setting for CRI for new measurements
- keep wavelength range setting for PAR for new measurements
- improved device selection dialog
[BUGFIX]
- update measuring values also in raw spectra view


V1.0.9

[BUGFIX]
- draw spectra fixed


V1.0.8

[BUGFIX]
- cursor error if wavelength range starts at <380 nm="" -=""> fixed


V1.0.7

[CHANGED]
- compiled with CVI 8.0.1


V1.0.6

[CHANGED]
- compiled with CVI 8.0
[BUGFIX]
- cursor could cause runtime error -> fixed


V1.0.5

[CHANGED]
- changed company address


V1.0.4

[BUGFIX]
- adaption fixed


V1.0.3

[CHANGED]
- revised adaption of integration time (adjusted min border and target counts)
[BUGFIX]
- coloured line in spectra view fixed
- adaption with split-time fixed


V1.0.2

[CHANGED]
- improved coloured line in spectra view
- accelerated spectral view
- revised adaption of integration time (use internal split-time)
[BUGFIX]
- reference file with radiant intensity could not be loaded -> fixed
- sometimes no adaption during calibration process -> fixed


V1.0.0

- first release of JETI LiMeS

Your request
Please calculate 8 plus 1.